Sumar si y sumar si conjunto en Excel

Sumar si y sumar si conjunto son dos de las funciones más utilizadas en Excel. Y por ello, si quieres manejar el programa con soltura es imprescindible que aprendas su uso paso a paso.

Diferencias entre sumar si y sumar si conjunto

Ambas funciones sirven para realizar sumas aplicando uno o varios criterios. Ahí es donde radica su principal diferencia.

  • SUMAR.SI te permite sumar valores que coinciden con un único criterio.
  • SUMAR.SI. CONJUNTO te permite sumar valores que cumplen varios criterios.

La función SUMAR.SI. CONJUNTO está disponible en Excel desde la versión 2007. Aún así, hay mucha gente que bien no sabe de su existencia o no ha utilizado nunca esta función.

Debes utilizar una u otra función cuando necesites realizar sumas aplicando una o varias excepciones en los valores a sumar.

El orden de los argumentos en estas dos funciones también es diferente, pero eso lo veremos en el uso de cada una de ellas.

Función SUMAR SI en Excel

Utiliza esta función cuando necesites realizar una suma de un rango de valores aplicando una excepción, o según un criterio.

Por ejemplo, en un listado de precios, sumar solo los mayores de 20€.

Para ver el uso de la función SUMAR.SI utilizaremos un ejemplo en el que se muestran 20 ventas de una tabla y para cada una de las ventas tenemos el importe, vendedor, sección y tipo de pago. Puedes descargarte la plantilla al final del post.

La sintaxis de la función es SUMAR.SI=(rango;criterio;[rango_de_suma]) donde:

  • Rango es el rango que quieres usar para aplicar el criterio o excepción de la suma.
  • Criterio es la “norma” que quieres aplicar.
  • Rango_de_suma es el rango que contiene los valores a sumar.

SUMAR SI aplicando criterio de texto

Si quieres sumar, por ejemplo, únicamente las ventas de la sección perfumería la función quedaría así:

=SUMAR.SI(C2:C21;»perfumería»;B2:B21)

En este caso el criterio lo hemos escrito directamente en la función, es por ello que siempre debe ir entre comillas para que la función no dé error. Otra opción sería seleccionar para el criterio la celda donde se encuentra el texto perfumería, en este caso no es necesario escribir comillas.

SUMAR SI aplicando criterio mayor que, menor que, igual que

También puedes aplicar criterios sobre valores, incluso el rango a sumar puede coincidir con el rango del criterio sin problema.

Si quieres sumar únicamente las ventas que superan los 30€ la función quedaría así:

=SUMAR.SI(B2:B21;F7;B2:B21)

sumar si y sumar si conjunto

Como puedes observar la celda F7 es el criterio y lo que aparece en esa celda es <30.

Otra forma de introducir este criterio en la función sería escribiéndolo en la propia función, en ese caso tendrías que escribir en el argumento criterio “<30” siempre entrecomillado para que la función no arroje error, quedando de la siguiente forma:

=SUMAR.SI(B2:B21;»<30″;B2:B21)

Y si en la celda de referencia solo apareciera el valor, sin el símbolo de menor que, tendrías que escribir en el argumento criterio “<”&F7 o bien “<”&30 en ambos casos la formula funcionaría correctamente.

=SUMAR.SI(B2:B21;»<«&F7;B2:B21)  o  =SUMAR.SI(B2:B21;»<«&30;B2:B21)

Función SUMAR SI CONJUNTO en Excel

Utiliza esta función cuando necesites realizar una suma de un rango de valores aplicando una o varias excepciones o según uno o más criterios.

Es decir, la función SUMAR SI CONJUNTO puede sustituir sin problema a la función SUMAR SI ya que es posible utilizarla con uno o varios criterios.

Si no estás familiarizado con estas dos funciones te aconsejamos que utilices siempre la función SUMAR.SI.CONJUNTO porque podrás aplicarla en todos los casos y porque al variar el orden de los argumentos en estas dos funciones evitas confusiones que pueden llevarte a error.

Observa la sintaxis de la función SUMAR.SI.CONJUNTO=(rango_suma;rango_criterio1;criterio1;rango_criterio2;criterio2…) donde:

  • Rango_suma es el rango que contiene los valores a sumar.
  • Rango_criterio1 es el rango que quieres usar para aplicar el primer criterio o excepción de la suma.
  • Criterio1 es la “norma” que quieres aplicar al primer rango_criterio.
  • Rango_criterio2 es el rango que quieres usar para aplicar el segundo criterio o excepción de la suma.
  • Criterio2 es la “norma” que quieres aplicar al segundo rango_criterio.

Y así podrías introducir hasta 29 criterios distintos.

Solamente se sumarán los valores que cumplan todos los criterios.

Aplica criterios de texto

Si quieres sumar las ventas de la sección perfumería que se han pagado al contado necesitas introducir 2 criterios, quedando la función así:

=SUMAR.SI.CONJUNTO(B2:B21;C2:C21;”PERFUMERÍA”;D2:D21;»contado»)

Observa que en este caso hemos introducido los criterios de texto escritos directamente en la función y por ellos es OBLIGATORIO que vayan entrecomillados.

No importa si escribes el texto en mayúsculas, minúsculas o la primera letra con mayúsculas. Pero NUNCA OLVIDES LAS TILDES o la función no encontrará el criterio.

Así también te dará el resultado correcto:

=SUMAR.SI.CONJUNTO(B2:B21;C2:C21;»PeRfUmErÍa»;D2:D21;»contado»)

sumar si y sumar si conjunto

Aplica varios criterios numéricos

Puedes aplicar tanto criterios de texto como numéricos y puedes mezclarlos. Es decir, puedes usar criterios de texto y numéricos en la misma función sumar si conjunto.

Para sumar las ventas de la sección perfumería realizadas al contado y que superen los 40€ la función quedaría así:

=SUMAR.SI.CONJUNTO(B2:B21;C2:C21;F9;D2:D21;”contado”;B2:B21;H9)

En el primer criterio de texto hemos utilizado la referencia a la celda F9 donde aparece el texto Perfumería. En el caso del criterio contado lo hemos escrito directamente en la función y en para aplicar el criterio numérico hemos utilizado la referencia a la celda H9 que contiene el texto >40

Puedes introducir criterios numéricos de las siguientes formas:

  • Con referencia a la celda que contenga la regla, ejemplo en la función anterior.
  • Escribiendo el criterio en la función con el símbolo y el valor numérico entrecomillado quedando =SUMAR.SI.CONJUNTO(B2:B21;C2:C21;F9;D2:D21;»contado»;B2:B21;«<40»)
  • Con el símbolo entrecomillado escrito en la función y utilizando el símbolo & para añadir el valor también escrito en la función, quedando: =SUMAR.SI.CONJUNTO(B2:B21;C2:C21;F9;D2:D21;»contado»;B2:B21;«<«&40)
  • Símbolo escrito en la función entre comillas y usando el símbolo & para hacer referencia a la celda que contiene el valor, quedando =SUMAR.SI.CONJUNTO(B2:B21;C2:C21;F9;D2:D21;»contado»;B2:B21;«<«&H9) en este caso en la celda H9 solo aparece el valor numérico sin símbolo.

Estas son las 4 formas de utilizar criterios numéricos en la función sumar si conjunto. Si olvidas las comillas la función te arrojará error.

sumar si y sumar si conjunto

También podrías sumar los valores mayores o iguales a 40. En ese caso el argumento quedaría así “>=”&40

Plantilla del ejercicio

⚠ Esta plantilla es un recurso creado por Saber Programas y su uso está sujeto a derecho de autor y propiedad intelectual.

Te puede interesar

Haz un comentario

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies