Función SI en Excel de básico a avanzado

Es posible que la función SI en Excel sea una de las funciones lógicas más utilizadas. Combinándola con otras funciones o utilizándola de forma anidada puedes conseguir funciones realmente potentes. En este tutorial te explicamos la función SI en Excel de básico a avanzado para que puedas sacarle el máximo partido.

Función SI en Excel |nivel básico|

La función SI te permite evaluar una condición y arrojar un valor en caso de que sea verdadera y un valor diferente en caso de que sea falsa.

La sintaxis de la función SI es:

=SI(prueba_lógica;[valor_si_verdadero];[valor_si_falso]) donde:

  • Prueba_lógica es la condición que quieres evaluar.
  • Valor_si_verdadero es el valor que la función SI devuelve cuando el resultado de la prueba lógica es VERDADERO. Puede ser un valor numérico, texto u otra función.
  • Valor_si_falso es el valor que la función SI devuelve cuando el resultado de la prueba lógica es FALSO. Puede ser un valor numérico, texto u otra función.

*El tercer parámetro de la función (valor_si_falso) es opcional, es decir, puedes omitirlo. En ese caso la función SI devuelve el valor predeterminado FALSO.

De forma más sencilla lo que hace la función SI es:

SI algo es verdadero, ENTONCES devuelve el primer valor, EN CASO CONTRARIO devuelve el segundo valor.

Normalmente la función SI se utiliza cuando necesitamos marcar los resultados en función de ciertas condiciones (por ejemplo, menor que, igual a, mayor que, etc.)

En el ejemplo queremos que la función SI evalúe si las ventas superan las 3000 unidades, en caso verdadero queremos que nos arroje el texto Objetivo alcanzado y en caso contrario no queremos que muestre nada.

La función SI quedaría de la siguiente forma:

=SI(B6>3000;”Objetivo alcanzado”;””)

📌Recuerda que para que Excel muestre un texto introducido en una función éste debe ir entrecomillado. Y si no quieres que se muestre nada solo debes escribir las comillas y nada más.

💡 Consejo: puedes escribir un valor numérico en la prueba lógica o usar una referencia de celda a una celda que contenga dicho valor. Si en el futuro decides cambiar la palabra “Objetivo alcanzado” por otra cosa solo tienes que cambiar el texto de la celda de referencia sin la necesidad de rehacer toda la fórmula.

Función SI + función Y

Cuando necesitas que se cumplan varias condiciones debes utilizar la función Y dentro de la función SI.

Aunque parezca complicado vas a comprobar que es bastante sencillo y puedes evaluar tantas condiciones como necesites.

La sintaxis de la función Y es muy simple:

=Y( valor_lógico1;valor_lógico2;…)

Simplemente te permite añadir cuantas pruebas lógicas necesites.

La sintaxis de la función SI junto con la función Y quedaría de la siguiente forma:

=SI(Y(valor_lógico1;valor_lógico2);valor_si_verdadero;valor_si_falso)

En el ejemplo queremos que cuando las ventas estén por encima de las 3000 unidades y por debajo de las 4000 unidades se muestre el texto Objetivo alcanzado.

Nuestras condiciones serían 2; valor>3000 y valor<4000. Se deben cumplir ambas condiciones.

En el ejemplo utilizado la función quedaría así:

=SI(Y(B21>$D$18;B21<$D$19);$D$20;””)

📌 Recuerda. Los símbolos de dólar $ indican que la referencia de esa celda es absoluta. Esto quiere decir que cuando copies la función en otra celda esas referencias permanecerán invariables.

Función SI anidada

La función SI anidada te permite evaluar múltiples criterios. En este caso la sintaxis de las funciones comienza a complicarse por lo que te recomendamos ser muy cuidadoso con el orden los valores de la función.

La mejor forma de explicar su funcionamiento es con un ejemplo, así que vamos a escribir una función que:

  • Muestre el valor Objetivo alcanzado cuando las ventas superen las 3000 unidades y estén por debajo de las 4000 unidades.
  • Muestre el valor Top ventas cuando las ventas sean iguales o superiores a 4000 unidades.
  • Si no se cumple ninguna condición entonces no queremos ningún resultado.

La primera parte de la función sería exactamente igual que en el ejemplo anterior. Debes introducir la segunda función SI en el parámetro [valor_si_falso]) de la primera función SI.

La sintaxis de la función quedaría así:

=SI(Y(valor_lógico1;valor_lógico2);valor_si_verdadero; SI(prueba_lógica;valor_si_verdadero; valor_si_falso))

En el ejemplo utilizado la función quedaría así:

=SI(Y(B36>3000;B36<4000);”Objetivo alcanzado”;SI(B36>=4000;”Top ventas”;””))

Donde B36 es la celda que estamos evaluando. Te hemos mostrado la sintaxis de la función del ejemplo sin utilizar referencias a celdas para que te resulte más sencillo de visualizar. Esa misma función utilizando las referencias a celdas quedaría así:

=SI(Y(B36>$D$32;B36<$D$33);$D$34;SI(B36>=$D$33;$D$35;””))

Puedes ver ejemplos más complejos de uso de la función SI anidada en el tutorial Función SI con varias respuestas.

Función SI + función O

Cuando necesites evaluar si se cumple alguna condición entonces debes utilizar la función O dentro de la función SI. En este caso si se cumple cualquiera de las condiciones establecidas se mostrará el valor establecido.

La sintaxis de la función O es muy sencilla:

=O( valor_lógico1;[valor_lógico2];…)

La sintaxis de la función SI junto con la función O quedaría de la siguiente forma:

=SI(O(valor_lógico1;valor_lógico2);valor_si_verdadero;valor_si_falso)

En el ejemplo queremos que cuando las unidades vendidas sean especialmente bajas o especialmente altas nos muestre el texto Informar.

Nuestras condiciones serían; ventas < 2000 unidades o ventas > 5000 unidades. Se tiene que cumplir ALGUNA de las condiciones para que se muestre el texto Informar.

En el ejemplo utilizado la función quedaría así:

=SI(O(B51<2000;B51>5000);”Informar”;””)

Como has visto es posible sacar mucho partido a la función SI si sabes combinarla con otras funciones.

Donde B51 es la celda que estamos evaluando.

Plantilla de ejemplo

Puedes descargarte la plantilla del tutorial aquí:

Esta plantilla es un recurso creado por Saber Programas y su uso está sujeto a derecho de autor y propiedad intelectual.




Ayúdanos a seguir creando contenido gratuito con una donación