Buscar por fila y columna en Excel; INDICE y COINCIDIR

Las funciones INDICE y COINCIDIR son la solución cuando no puedes usar la función BUSCARV para realizar la búsqueda que necesitas. Como sabes la función BUSCARV busca valores según el valor que aparece en la primera columna. Pero… ¿Qué pasa cuando tu valor de referencia para la búsqueda se encuentra en otra columna que no es la primera? En esos casos BuscarV no sirve.

Función INDICE en Excel

Para usar las funciones INDICE y COINCIDIR juntas primero debes aprender cómo funcionan por separado. Empezaremos viendo la función INDICE. La descripción de Excel de la función Índice es la siguiente:

“Devuelve un valor o referencia de la celda en la intersección de una fila y columna en particular, en un rango especificado”.

Dicho de otra forma, debes establecer un rango de búsqueda y especificar una fila y columna, la función índice te devolverá el valor que aparezca en la celda que coincida con la posición indicada por la fila y columna.

INDICE y COINCIDIR

La sintaxis de la función es =INDICE(matriz;núm_fila;[num_columna]) donde:

  • Matriz es el rango de datos donde está el valor que buscas.
  • Núm_fila es el número de fila dentro del rango donde se encuentra el valor buscado.
  • Núm_columna es el número de columna dentro del rango donde se encuentra el valor buscado. El número de columna aparece entre corchetes porque es un argumento opcional en la función ÍNDICE, puesto que en rangos de una sola columna no es necesario indicar este argumento.
INDICE Y COINCIDIR

En el ejemplo que facilitamos si quisiéramos obtener las Ventas del comercial Diego la función índice quedaría así:

=INDICE(E4:E13;5) podemos omitir el tercer argumento porque la matriz que hemos establecido solo tiene una columna.

También funcionaría si escribieras la función así: =INDICE(E4:E13;5;1) o =INDICE(E4:E13;5;0)

En ambos casos Excel entiende que quieres realizar la búsqueda en la única columna del rango. Pero si escribes cualquier otro número en el tercer argumento, por ejemplo =INDICE(E4:E13;5;2) el resultado de la función será #¡REF! porque Excel no puede buscar en la segunda columna ya que no existe en el rango que has especificado.

Como puedes imaginar no vamos a introducir a mano el valor numérico que establece en qué fila debe buscar la función INDICE, ahí es donde entra en juego la función COINCIDIR.

Función COINCIDIR en Excel

La función COINCIDIR nos devuelve un valor numérico que expresa la posición del valor buscado en la matriz establecida.

Es decir, de la función COINCIDIR vamos a obtener el valor numérico que marca la posición del valor buscado.

La sintaxis de la función =COINCIDIR(valor_buscado;matriz_buscada;[tipo_de_coincidencia]) donde:

  • Valor buscado es, como su propio nombre indica, el valor del que queremos conocer la posición.
  • Matriz buscada es el rango de celdas donde se encuentra el valor buscado.
  • Tipo de coincidencia, en este argumento siempre necesitarás una coincidencia exacta, por lo que debes indicar el valor 0.

Para obtener la posición del vendedor Diego la función quedaría así:

=COINCIDIR(I3;C4:C13;0) y te devolverá el valor 5.

Recuerda que cuando uses la función COINCIDIR la matriz buscada debe ser una única fila o columna, ya que la función te devolverá la posición del valor buscado con un único número. Si para el argumento matriz buscada seleccionas un rango de más de una columna la función te devolverá el valor #N/D que es un valor de error que significa que «no hay ningún valor disponible».

Funciones INDICE y COINCIDIR juntas

Ya estarás imaginando cómo puedes usar estas dos funciones juntas para realizar la búsqueda que necesitas. Aun así, vamos a verlo paso a paso.

En el ejemplo queremos que eligiendo uno de los comerciales del desplegable Excel nos muestre los datos que hemos establecido; área, unidades vendidas y ventas.

Comenzaremos con el primer caso, área. Coloca el cursor del ratón en la celda donde quieres obtener el resultado y escribe =INDICE donde;

  • Matriz es el rango de celdas donde se encuentra el dato que quieres obtener. En el primer ejemplo será el rango B4:B13 que es donde se encuentran las áreas de todos los comerciales.
  • En el segundo argumento núm_fila utiliza la función COINCIDIR que te arrojará el valor numérico que indica la fila donde se encuentra el comercial seleccionado. Quedando COINCIDIR(I3;C4:C13;0)
  • El tercer argumento no es necesario en este caso

La función quedaría así: =INDICE(B4:B13; COINCIDIR(I3;C4:C13;0))

Observa como tanto en la matriz de la función INDICE B4:B13 como en la matriz de búsqueda de la función COINCIDIR C4:C13 coinciden las filas. Esto es imprescindible para que la función no te de error. Las matrices de búsqueda deben tener la misma extensión.

Para obtener las unidades vendidas y las ventas puedes copiar la función y cambiar el rango de la función INDICE para obtener el valor correcto. Selecciona la función y cópiala presionando CTRL+C, pulsa la tecla ESC, coloca el cursor en la celda de unidades vendidas y pega la función presionando CTRL+V.

Ahora solo tienes que cambiar el rango matriz de la función INDICE para obtener el valor buscado. Repite la operación para obtener las ventas.

Función INDICE Y COINCIR en fila y columna

En este último apartado vamos a “darle una vuelta de tuerca más” a la combinación de índice y coincidir y vamos usar la función COINDICIR tanto para establecer la fila como la columna de búsqueda de la función INDICE.

Para ello, crea una lista desplegable para elegir el dato a buscar. En este caso escribe los valores, ya que si seleccionas el encabezado también aparecerá la opción comercial en el desplegable del dato a mostrar.

Una vez que tienes los dos desplegables puedes comenzar a armar la función.

Como en los casos anteriores debes utilizar la función Indice donde:

  • Matriz es el rango de datos donde está el valor que buscas, en este caso necesitas seleccionar 3 columnas ya que dependiendo de lo que se muestre en el desplegable el valor buscado estará en una u otra columna, por lo que selecciona todo el rango del ejemplo B4:E13.
  • Núm_fila vendrá determinado por la función COINCIDIR que buscará la posición del comercial seleccionado en la columna COINCIDIR(I3;C4:C13;0)
  • Núm_columna en este caso sí debemos incluir este argumento porque la matriz que hemos seleccionado para la función INDICE tiene 4 columnas. Utiliza de nuevo la función coincidir que en este caso dependerá del dato que se muestra en el desplegable COINCIDIR(H4;B3:E3;0)

La función quedaría =INDICE(B4:E13; COINCIDIR(I3;C4:C13;0); COINCIDIR(H4;B3:E3;0))

Consejo para dominar las funciones INDICE y COINCIDIR

Si estás acostumbrado a usar la función BUSCARV seguirás utilizándola siempre que puedas. Si quieres aprender definitivamente el uso de estas dos funciones juntas INDICE y COINCIDIR nuestro consejo es que las uses incluso cuando puedas utilizar BUSCARV.

De esta forma conseguirás estar tan familiarizad@ con estas dos funciones que podrás aplicarlas en cualquier situación en la que la BuscarV no funciona por sus limitaciones.

Plantilla del ejercicio

⚠ Esta plantilla es un recurso creado por Saber Programas y su uso está sujeto a derecho de autor y propiedad intelectual.


¡Puntúa este artículo!

Haz clic en las estrellas para puntuar

Promedio 5 / 5. Recuento de votos 2

Haz un comentario

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies