Excel – Calcular horas turno nocturno o diurno con una sola fórmula

Si necesitas llevar un control de tiempo de tus horas de trabajo o cualquier otra actividad, puedes hacerlo fácilmente utilizando Excel.

Calcular horario en un mismo día

Cuando el periodo de tiempo que queremos calcular transcurre en un mismo día es muy sencillo realizar el cálculo en Excel. Un ejemplo sería; calcular el tiempo transcurrido entre las 8:00 y las 16:30.

Para ello podemos crearnos una tabla sencilla en Excel con una columna para hora de inicio y otra columna para la hora de finalización. Aplicaremos un formato Hora a las celdas que van a contener los datos. Para calcular el tiempo transcurrido aplicaremos una fórmula sencilla:

= hora de salida – hora de entrada. En nuestro ejemplo   =B2-A2

caluclar tiempo en excel

Calcular horas turno nocturno o diurno con una única fórmula

Si necesitas calcular el tiempo transcurrido para un horario nocturno. Por ejemplo, el tiempo transcurrido entre las 22:00 y las 06:00 del día siguiente, la fórmula anterior no te servirá. En ese caso deberías utilizar la fórmula =B2-A2+24

Vamos a utilizar la función SI para que Excel calcule correctamente el tiempo transcurrido tanto si se trata de un horario en un mismo día, como si la hora de finalización se produce al día siguiente de la hora de inicio.

Lo que queremos es que Excel aplique una fórmula distinta en los siguientes casos:

  • =B2-A2 para hora de finalización mayor que hora de inicio.
  • =B2-A2+24 para hora de finalización menor que hora de inicio.

Según nuestro ejemplo escribiremos la fórmula siguiente:

=SI(B2<A2;B2-A2+24;B2-A2)

calcular horas turno nocturno Excel

De esta forma obtendrás siempre el calculo correcto independientemente de si se trata de un turno de noche o de día.

calcular horas turno nocturno